Soleado

Soleado

diciembre 25, 2018 Formulario 0

¿Ya eres Miembro?

Para Descargar este Plugin




Descripción

Purgar automáticamente el caché de Cloudflare, incluidas las reglas de caché de todo.

¡¡¡Advertencia!!!

Este plugin no es para usuarios normales! Lea todo el archivo Léame y las Preguntas frecuentes antes de instalar.

Cloudflare caché: todas las reglas rompen la mayoría de las funcionalidades dinámicas de WordPress:

  • WordPress Nonces será cacheado

  • Los formularios se deben cargar a través de AJAX a menos que esté utilizando el plan Cloudflare de USD $ 200. Aprende más

Sunny muestra algunos avisos de administración en el panel de administración de WP que promocionan los servicios de desarrollo web del autor cada 2 semanas. Se pueden descartar a través de X botón en la esquina derecha. Consulte las preguntas frecuentes para obtener más información. Este es un complemento gratuito, gratuito y gratuito. Siempre puede eliminar esos avisos sin romper otras partes de Sunny.

El próximo lanzamiento importante de Sunny (v3.0.0) requerirá:

  • PHP 7.1
  • WordPress 4.9
  • Trabajando adecuadamente WP Cron

Caracteristicas

  • Purgar automáticamente Cloudflare caché todo cachés de reglas
  • Utiliza la última API de Cloudflare v4
  • Soporte de tipo de mensaje personalizado
  • Ocultar la barra de administración de las páginas públicas
  • Soporte WP REST API
  • Contenedor tipo Laravel extensible

Depuradores

Ir Soleado -> Depuradores, muestra:

  • Todas las URL relacionadas deben ser purgadas para un puesto dado
  • Mostrar urls dirigidas que siempre deben ser purgadas.
  • Estado de caché de una URL dada

¿En qué se diferencia Sunny del complemento oficial de Cloudflare?

En el momento de escribir este artículo, el complemento oficial de Cloudflare no se purga caché todo caches de reglas ¡Aquí viene Sunny! Foco soleado en la purga de escondites cuando sea necesario.

Compatibilidad

  • Funciona con el plugin oficial de Cloudflare.
  • Funciona con WP Cloudflare Guard (crear automáticamente reglas de firewall para bloquear IPs peligrosas).

Cosas que necesitas saber

  • Necesitas PHP 7.0 o después
  • Necesitas wordpress 4.7 o después
  • Necesitas una cuenta en Cloudflare (plan gratuito está bien)
  • Este complemento no fue construido por Cloudflare, Inc.

Si le gusta el complemento, siéntase libre de calificarlo o donar. ¡Muchas gracias! 🙂

Apoyo

Para ahorrar tiempo y poder gastarlo en desarrollo, lea primero las Preguntas frecuentes del complemento. Antes de solicitar asistencia, asegúrese de haber actualizado Sunny y WordPress a la última versión publicada y de haber instalado PHP 7 o posterior.

Puede obtener asistencia a través de los problemas de GitHub (preferido) y el foro de soporte de WordPress.

Si no proporciona esta información, su ticket de soporte será ignorado:

  • Número de versión de PHP (si usted dice último, su boleto será cerrado sin respuestas)
  • Número de versión de WordPress
  • Número de versión soleado
  • ¿Cuál es el comportamiento actual?
  • ¿Cuál es el comportamiento esperado o deseado?
  • Paso para reproducir el comportamiento actual.
  • ¿Se comporta igual cuando Sunny está deshabilitado?
  • ¿Se comporta igual cuando solo Sunny está habilitado?
  • ¿Qué has tratado de resolver el problema?

Para desarrolladores

Sunny es de código abierto y está alojado en GitHub. Siéntase libre de hacer solicitudes de extracción.

También puedes pellizcar Soleado para trabajar para usted extendiendo su contenedor tipo Laravel.

Capturas de pantalla

  • Configuraciones Cloudflare
  • Configuración de la barra de administración
  • Purgar cuando Post Actualizado
  • Depuradores – Estado de caché para una URL dada
  • Debuggers – URLs relacionadas para una publicación dada
  • Depuradores – URLs adicionales para cada purga
  • Molesto Sunny v1 desaprobado aviso

Preguntas más frecuentes

¿Cómo puedo purgar URLs adicionales?

Post urls relacionados son filtrables por Estrategias y sunny_post_related_urls. Ver ejemplos en el Ejemplo de URL de Sunny Purge Extra.

Si no entiendes el código de ejemplo, contrátame.

¿Cómo puedo hacer que Sunny trabaje para mis necesidades especiales?

Extiende su contenedor tipo Laravel.

¿Qué versión de PHP necesito?

PHP 7.0 o después.

¿Qué versión de WordPress necesito?

WordPress 4.7 o después.

¿Qué hacer cuando “error de análisis: error de sintaxis”?

Si has encontrado este error:

Error de análisis: error de sintaxis, inesperado ‘:’, esperando ‘;’ o ‘{‘ en wp-content / plugins / sunny / src / Sunny.php en la línea XX

Probablemente estés ejecutando en una versión antigua de PHP. Actualiza tu servidor a PHP 7.0 o después.

Incapaz de despedir anuncios

Sunny muestra algunos avisos de administración en el panel de administración de WP que promocionan los servicios de desarrollo web del autor cada 2 semanas.
Son desechables a través de la X botón en la esquina derecha.

¿Por qué no se van?
Tu configuración de caché es incorrecta! Posibles problemas:

  • Las memorias caché de consulta de la base de datos no se han eliminado al actualizar
  • Caché de objetos caducan demasiado tiempo
  • Cloudflare es el almacenamiento en caché wp-admin

Sunny trabaja con el caché de consultas de base de datos y el caché de objetos Este complemento no solucionará la configuración incorrecta del servidor.

Pero … ¿otros plugins no tienen este problema?

Yo dudo. Sunny guarda / recupera esos avisos a través de la API de Opciones que se usa comúnmente en los complementos. Por lo tanto, otros complementos también deberían tener opciones obsoletas. ¡Contrata un desarrollador para revisar tu sitio!

Si aún no está convencido, envíe una solicitud de extracción con caso de prueba fallido a través de GitHub.

¿Debo instalar la versión 1 de Sunny debido a incompatibles con PHP 5?

No. La versión 1 de Sunny usa la API v1 de Cloudflare, que está en desuso desde el 9 de noviembre de 2016. Actualice su servidor o desinstale Sunny.

¿No sabes cómo actualizar PHP?
  • Póngase en contacto con su empresa de alojamiento
  • Cambie a un mejor alojamiento como WP Engine o Kinsta
  • Contrátame https://typist.tech/contact
¿Soportarás versiones anteriores de PHP o WordPress?

Depende. Acepto este tipo de trabajos de codificación personalizados. Sin embargo, prepárese para ser rechazado si el requisito no tiene sentido.
Envíeme un correo electrónico a [email protected] o utilice este formulario de contacto.

¿Este plugin está escrito por Cloudflare, Inc.?

No. Este plugin es un proyecto de Typist Tech.

¿Quién hace este plugin?

Tang Rufus, un desarrollador freelance de alquiler. Hago Typist Tech también.

¿Puedo instalar el complemento oficial de Sunny, Sunny y Cloudflare al mismo tiempo?

Sí, todos ellos trabajan juntos sin problemas.

  • Instale WP Cloudflare Guard si desea proteger su sitio de IP incorrectas
  • Instala Sunny si quieres purgar el caché de Cloudflare automáticamente
  • Instala el complemento oficial si no puedes ver la IP real de los visitantes
¿Este plugin está disponible en mi idioma?

Inglés trabaja fuera de la caja.

El paquete de idioma chino tradicional está disponible aquí.

Puedes agregar tu propia traducción en translate.wordpress.org.

¿Cómo conseguir apoyo?

¡Lea primero el léame completo y las preguntas frecuentes!

¿Cómo puedo soportar este plugin?

Si te gusta el plugin, siéntete libre de:

  • Danos una revisión de 5 estrellas en WordPress.org
  • Traducirlo en translate.wordpress.org
  • Donar. ¡Muchas gracias! 🙂

Además, Soleado es de código abierto y alojado en GitHub. Siéntase libre de hacer solicitudes de extracción.

Por último, pero no menos importante, puedes contratarme. Envíeme un correo electrónico a [email protected] o utilice este formulario de contacto.

¿Y si quiero más?

¡Contratame! Envíeme un correo electrónico a [email protected] o utilice este formulario de contacto.

Opiniones

Ha sido una navegación suave con Sunny!

eyedeal

Este plugin me funciona todos los días en varios sitios. Gran producto a muy buen precio. ¡Altamente recomendado!

Hace el trabajo de purgar cloudflare!

Amaravati

pero tiene una pantalla de notificación todo el tiempo … .. un poco molesto.

Gran plugin, HORRIBLE NAG SCREEN

WPjohnny.com

Lamento haber llegado a esto, pero no pude soportarlo más. Después de 6 meses de desactivar la pantalla nag en la parte superior del panel de control cada vez que inicie sesión (le ruego que revise el complemento en el repositorio de WP), no pude evitar obligar a escribir esta bien merecida revisión. El plugin funciona fantásticamente pero es increíblemente molesto. No puedo usarlo para los clientes debido a las pantallas molestas y no puedo seguir usándolo por mucho tiempo.

Recorte la basura o al menos dénos la opción de pagarle $ 1 para que deje de pedirnos que dejemos una revisión.

Mensajes constantes de Nag

Alan

El complemento hace lo que dice, pero los mensajes molestos constantes son una broma.

Funciona perfectamente como se describe

Ashwin Singh

Funciona exactamente como se describe. Ve a por ello. Solo necesita una opción más de Purgar todo en la barra de administración de WordPress.

Inserciones publicitarias para servicios web competidores.

mofetas

Me encantaba este complemento hasta que descubrí que estaba mostrando anuncios (alertas internas) para los servicios de diseño web del autor en docenas y docenas de sitios web de mis clientes que cuido.

Esto parece muy poco profesional. Tendré que dejar de usar este complemento ahora y eliminarlo de todos los sitios de mi cliente.

Leer las 25 críticas.

Colaboradores y Desarrolladores

“Sunny” es un software de código abierto. Las siguientes personas han contribuido a este plugin.

Contribuyentes

“Sunny” ha sido traducido a 2 locales. Gracias a los traductores por sus contribuciones.

Traduce “Sunny” a tu idioma.

¿Interesado en el desarrollo?

Busque el código, revise el repositorio SVN o suscríbase al registro de desarrollo por RSS.

Registro de cambios

Registro de cambios completo disponible en GitHub

2.5.0

  • Quitar clase I18n
  • Dependencias de actualización
  • Actualizar readme

2.4.1

  • Agregue la versión requerida de php a README.txt
  • Aplicar parches de estilo de código y refactorización menor.
  • Prueba en PHP todas las noches
  • Dependencias de actualización

2.4.0

  • Proveedor de servicios de extracción de objetivos
  • Mostrar el nombre del tipo de publicación en los avisos de purga iniciados

2.3.0

  • Expone Container a través de la acción de WordPress en estilo Laravel

2.2.1

  • Solución: asegúrese de que los administradores tengan la oportunidad de ver un aviso no compatible con PHP 5.x
  • Solución: no forzar el aviso fijo cuando WP_DEBUG es verdadero

2.2.0

  • Purgar los mensajes adyacentes a las URL.
  • Depurador: compruebe si Cloudflare almacena en caché una url
  • Añadir muchas pruebas

2.1.0

  • Mejor soporte WP REST API
  • Página de inicio de purga (tanto dinámica como estática)
  • Agregar un depurador: muestra todas las direcciones URL que se deben depurar para una publicación determinada
  • Agregar depurador: muestra las direcciones URL específicas que siempre se deben eliminar.
  • Arreglo: Falta la url del mensaje al purgar

2.0.1

  • Auto desactivación si la versión de PHP es más antigua que 7.0.0

2.0.0

  • Actualizar a la API de Cloudflare v4
  • Reescritura de la base de código

¿Ya eres Miembro?

Para Descargar este Plugin



Por favor Comparte y Síguenos:
RSS
Follow by Email
Facebook
Twitter

Deja un comentario