Q2W3 Widget fijo - KolMitE

Q2W3 Widget fijo

Q2W3 Widget fijo

noviembre 30, 2018 Populares 0


Descripción

Habilite la opción “Widget fijo” en la configuración del widget y estará siempre a la vista cuando la página se desplace hacia arriba o hacia abajo. ¡No hay ningún problema para “arreglar” o “pegar” más de un widget, incluso en diferentes barras laterales!

¡Demo en vivo!

Nuevo en la versión 5.0:
1. Rendimiento optimizado del lado del cliente. La detección de cambios de página ahora se basa en la API MutationObserver. El recuento de parámetros de widgets se activa solo cuando es necesario! La opción de intervalo de actualización se usa solo para la compatibilidad con navegadores antiguos (no es compatible con MutationObserver API).
2. Compatibilidad mejorada con complementos de almacenamiento en caché (W3TC, Autoptimize y etc.). ¡No es necesario excluir los archivos jQuery y plugin de la caché!
3. Soporte del método de carga de script Async / Defer
4. Agregado Deshabilitar ancho y Deshabilitar la altura opciones

Nota para los usuarios de complementos de caché. ¡No olvide borrar el caché después de actualizar a la versión 5! Se ha cambiado el formato de opciones!

Nota de compatibilidad. ¡El plugin no funciona con todos los temas! Requisitos del tema:

  • jQuery 1.7 requerido. Se recomienda jQuery 1.8.3 (o posterior).
  • No hay errores de JavaScript, utilizados por otros complementos y scripts.
  • wp_head () y wp_footer () Funciones en los archivos header.php y footer.php.
  • Los widgets deben tener un atributo de id.

En algunos casos (widget “saltar” durante el desplazamiento y etc.) los cambios de CSS del tema pueden ser necesarios.

Instalación

  1. Siga el procedimiento estándar de instalación del complemento de WordPress
  2. Active el complemento a través del menú Complementos en WordPress
  3. Vaya a Apariencia -> Widgets, habilite la opción “Widget fijo” en cualquier widget activo
  4. Ajuste los parámetros del complemento en Apariencia -> Página Opciones de widgets fijos

Preguntas más frecuentes

Instrucciones de instalación
  1. Siga el procedimiento estándar de instalación del complemento de WordPress
  2. Active el complemento a través del menú Complementos en WordPress
  3. Vaya a Apariencia -> Widgets, habilite la opción “Widget fijo” en cualquier widget activo
  4. Ajuste los parámetros del complemento en Apariencia -> Página Opciones de widgets fijos
¿Por qué el plugin no funciona?

Hay varias razones:

  1. Errores de Javascript en la página. Comúnmente causado por los complementos de buggy. Compruebe la consola javascript de su navegador. Si encuentra errores, intente localizar y corregir su origen.
  2. No wp_head () y wp_footer () Funciones en plantilla. Verifique los archivos header.php y footer.php de su tema activo.
  3. Conflictos con otros complementos y scripts.
  4. Incompatibilidad de CSS
¿Por qué el complemento no funciona en Chrome (y en otros navegadores basados ​​en Webkit)?

Revise sus archivos CSS para estas dos instrucciones:
-webkit-backface-visibilidad: oculto;
-webkit-transform: translate3d (0,0,0);
Si los encuentra, desactívelos y vea el resultado.

¿Cómo evitar la superposición con el pie de página?

Vaya al área de administración de WP, Apariencia -> Opciones de widgets fijos. Aquí puede definir los márgenes superior e inferior. Establecer el valor del margen inferior> = altura del pie de página. Compruebe el resultado.
Si la altura de su pie de página cambia de página a página, es mejor usar Detener la identificación opción. Aquí es necesario proporcionar ID de etiqueta html. La posición de ese elemento html determinará el valor del margen inferior. Por ejemplo, tomemos el tema por defecto de Twenty Sixteen. El contenedor de pie de página del tema tiene un id = “colophon”. En el Detener la identificación ¡Opción que necesito para ingresar solo colofón, sin ningún otro símbolo!

¿Cómo deshabilitar el plugin en dispositivos móviles?

Hay dos opciones: Deshabilitar ancho y Deshabilitar la altura. Funcionan de la misma manera. Si el ancho / alto de la ventana del navegador es menor o igual al valor especificado, el complemento está deshabilitado.

Opiniones

Bueno

vedepthanthai.com

uso fácil

Muy bien

Jordy Meow

No es un complemento muy fácil de hacer, pero funciona muy bien. Gracias 🙂

Sencillo pero, efectivo.

faiver

Gran herramienta

Funcionando perfectamente + Soporte impresionante

tidus457

Este complemento es realmente increíble, funciona perfectamente y Max Bond está haciendo un gran soporte para ayudarlo a que funcione con su tema. ¡Muy recomendable!

Buen plugin

trongnv

Este es el complemento perfecto!

retirar

Nykess

retirar

Leer las 216 reseñas.

Colaboradores y Desarrolladores

“Q2W3 Fixed Widget” es un software de código abierto. Las siguientes personas han contribuido a este plugin.

Contribuyentes

“Q2W3 Fixed Widget” se ha traducido a 5 locales. Gracias a los traductores por sus contribuciones.

Traducir “Widget fijo Q2W3” a su idioma.

¿Interesado en el desarrollo?

Examine el código, visite el repositorio de SVN o suscríbase al registro de desarrollo por RSS.

Registro de cambios

5.1.4

  • Compatibilidad mejorada con el complemento de anuncios avanzados. Se agregó el filtro “q2w3-fix-widgets”.

5.1.3

  • Ahora compatible con el plugin WP Page Widget

5.1.2

  • ¡Ahora funciona bien con los widgets de Shortcodes Ultimate!

5.1.1

  • ¡Resuelve problemas con Margin Bottom y Stop ID de la versión 5.1!

5.1

  • Nuevas opciones de método de carga!
  • Probado con WordPress 4.9

5.0.4

  • Parche de compatibilidad para el plugin Better WordPress Minify.

5.0.3

  • Solución mejorada para el error “q2w3_sidebar_options no está definido”.

5.0.2

  • Optimizacion javascript plugin
  • Para resolver el error “q2w3_sidebar_options no está definido” wp_add_inline_script Se utiliza la función. WordPress 4.5 requerido para esta revisión!
  • Opción añadida Deshabilitar MutationObserver. ¡Utilice esta opción solo como una copia de seguridad para restaurar el comportamiento de la versión 4!

5.0.1

  • Problema solucionado en el diseño de múltiples barras laterales

5.0

  • Rendimiento optimizado del lado del cliente. La detección de cambios de página ahora se basa en la API MutationObserver. El recuento de parámetros de widgets se activa solo cuando es necesario! La opción de intervalo de actualización se usa solo para la compatibilidad con navegadores antiguos (no es compatible con MutationObserver API).
  • Compatibilidad mejorada con complementos de almacenamiento en caché (W3TC, Autoptimize y etc.). ¡No es necesario excluir los archivos jQuery y plugin de la caché!
  • Soporte de método de carga de script Async / Defer
  • Adicional Deshabilitar ancho y Deshabilitar la altura opciones
  • Nota para los usuarios de complementos de caché: ¡no olvide borrar el caché después de actualizar a la versión 5! Se ha cambiado el formato de opciones!

4.1

  • Adicional Detener la identificación opción. Úsalo cuando no puedas especificar Margen inferior valor. Solución proporcionada por Julian_Kingman!
  • ¡Ahora el complemento es consciente de la presencia de la barra de administración de WordPress!
  • Arreglado la destrucción de jQuery (ventana) .load gancho. ¡No debería haber problemas con otros complementos de jQuery ahora!
  • Añadida traducción al alemán
  • Soporte actualizado de internacionalización.

4.0.6

  • Una pequeña corrección de errores
  • Traducción al francés añadida

4.0.5

  • Nueva opción “Heredar el ancho del widget del contenedor principal” para admitir mejor diseños sensibles.
  • Optimización de Javascript.

4.0.4

  • Se agregó la opción “Auto fix widget id”. Está activado de forma predeterminada. Si el complemento funciona con esta opción desactivada, ¡déjela en la posición de apagado!

4.0.3

  • Código optimizado para resolver la falla del plugin después del problema de actualización 4.0.1
  • Código javascript minificado

4.0.1

  • Hotfix! Elimina problemas con código de widget duplicado.

4.0

  • Resuelto widget de saltar
  • Código agregado para reparar automáticamente el “problema de id de widget”
  • Nueva opción de compatibilidad agregada (prioridad del complemento)
  • Se agregó una desinstalación completa (el script de desinstalación se inició automáticamente cuando DELETE el complemento)
  • Añadida traducción al español
  • Opciones eliminadas eliminadas

3.0

  • ¡Esta versión le brinda una capacidad de larga espera para pegar widgets ubicados en diferentes barras laterales! ¡Disfrutar!
  • Solucionado el conflicto con el plugin WP Page Widget
  • Unos pequeños bichos limpiados
  • ¡Advertencia! Las opciones “Deshabilitar el complemento en dispositivos móviles” y “Deshabilitar el complemento en dispositivos de tableta” ahora están limitadas y se eliminarán en la próxima versión. ¡Utilice la opción “Ancho máximo de pantalla” en su lugar!

2.3

  • Ahora el usuario puede deshabilitar el complemento, cuando el ancho de la ventana del navegador es menor que el valor especificado (verifique las opciones del complemento).

2.2.4

  • Esta versión es compatible con jQuery 1.9 y 1.10.

2.2.3

  • Pequeñas mejoras internas.
  • Detección móvil actualizada a la versión 2.6.0

2.2.2

  • Error PHP corregido
  • Detección móvil actualizada a la versión 2.5.8

2.2.1

  • Se corrigió la advertencia de PHP

2.2

  • Ahora, el complemento puede reflejar cambios dinámicos en el contenido de la página (desplazamiento infinito, cesta de ajax y otras cosas de javascript).
  • Se ha agregado una nueva opción a la configuración del complemento: Actualizar intervalo. Valores recomendados entre 500 y 2000 milisegundos. Nota: la configuración tiene un impacto en el rendimiento del sitio (lado del cliente). Si no tiene contenido dinámico, configure el Intervalo de actualización = 0.
  • Clase de Detección móvil actualizada a la versión 2.5.7

2.1

  • Nueva opción para definir ID de widgets personalizados para barras laterales estáticas y etc.
  • Nueva opción para deshabilitar el plugin en dispositivos móviles.
  • Se solucionó el error de javascript cuando no existen barras laterales en una página.

2.0

  • ¡Solucionado el problema de superposición de pie de página! Ahora los usuarios pueden personalizar los márgenes superior e inferior para los widgets fijos desde el área de administración (Apariencia -> Opciones de widgets fijos).
  • Añadido soporte de localización

1.0.3

  • Comportamiento del complemento normalizado cuando la barra lateral es más larga que el contenido principal. Nota: la posible superposición con el pie de página todavía existe.

1.0.2

  • Se solucionó el problema con los widgets que se muestran solo en ciertas páginas.
  • Código javascript optimizado.

1.0.1

  • Compatibilidad mejorada con navegadores basados ​​en Webkit (como Chrome y Safari).
  • Eliminado CSS innecesario.

1.0

  • Primer lanzamiento público.

Por favor Comparte y Síguenos:
RSS
Follow by Email
Facebook
Twitter

Deja un comentario